How to upgrade Mac OS for Zoom App

 

 

 

 

Zoom supports Mac OS X Snow Leopard 10.6 and later.

If you are running Mac OS X Leopard 10.5.x and want to upgrade to Snow Leopard / 10.6 or Lion / 10.7, please refer to the following from Apple:

 

Leave a Comment